Ask Your Question

Why does GenomeBrowse terminate when clicking to Plot icon?

asked 2018-09-10 04:53:43 -0600

Tibor Vaszkó gravatar image

updated 2018-09-10 05:38:55 -0600

I have been using GenomeBrowse 3.0.0 for several months in Ubuntu 16.04 LTS operating system. It worked well until last week. I can view anything in an existing project even now. However, when I click at the Plot icon to add new samples to a project, it exits with the following message:

terminating Aborted (core dumped)

I re-installed GenomeBrowse 3.0.0. Unfortunately, it failed to help.

Can you tell me the reason for that behavior? What should I do to fix that problem?

Thank you in advance for your help!

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted

answered 2018-10-09 04:45:12 -0600

Tibor Vaszkó gravatar image

Hi Gabe!

Thank you for your answer. I installed the RHEL version of GenomeBrowse. However, when I try to open the software, the following message appears:

/opt/GenomeBrowse/GenomeBrowse.bin: /opt/GenomeBrowse/lib/ version `CXXABI1.3.8' not found (required by /usr/lib/x8664-linux-gnu/

I tried some suggestions found in web forums to solve the issue but the problem still exists. Do you have any idea?

Anyway, the original problem with the Lin64 version may be caused by some software update. As I remember, the Ubuntu Software Center recommended then a samba update which I accepted. After that, the Plot icon never worked. Is it possible that the problem is due to a new version of either samba or Nautilus?

Is there any chance that upgrading 16.04 LTS to 18.04 LTS will make any of the two GenomeBrowse versions work well?


edit flag offensive delete link more


Sorry, I didn't mean this as an answer to my own question. I just wanted to make a remark.

Tibor Vaszkó ( 2018-10-09 04:59:47 -0600 )edit

Hi Tibor, We are looking at bundling changes to be more compatible with more versions of Linux (binary compatibility is like walking a tight-rope). One thing you can try is moving the bundled `lib/` out of the way. That may allow GB to run with the RHEL binaries.

Gabe Rudy ( 2018-10-09 08:41:58 -0600 )edit

Hi Gabe, I removed the lib/ file. Now the RHEL version opens, but it behaves in the same way as the Lin64 version. By clicking at the Plot icon, it says: terminating Aborted (core dumped). I suspect, some changes in the updated operation system may be responsible for it. What can I do?

Tibor Vaszkó ( 2018-10-10 06:40:11 -0600 )edit

Hi Tibor, It is possible, and the tricky thing with Linux is it is very hard for me to help reproduce / debug this. You may want to try updating to 18.04 (which the RHEL build works in our own testing). If that does not work, email me at my last name at

Gabe Rudy ( 2018-10-10 08:01:37 -0600 )edit

answered 2018-10-05 11:45:18 -0600

HI Tibor,

It's unusual that this happened all of a sudden. There could be some issue with a file that the Plot dialog is trying to scan.

You can also try to install the RHEL version of GenomeBrowse, which we are considering making the default / only linux binary as it has been shown to be compatible with all linux distros:


edit flag offensive delete link more
Login/Signup to Answer

Questions should be tagged FeatureRequest for asking about a non-existing feature or proposing a new idea, GeneralInquiry for general questions about GenomeBrowse or directions on how to do something, or RanIntoProblem if you want to report an issue or had difficulty getting to an expected result.

Question Tools

1 follower


Asked: 2018-09-10 04:53:43 -0600

Seen: 960 times

Last updated: Oct 09 '18