gautil coverage failing to identify genome assembly

asked 2019-02-27 18:14:04 -0700

I am trying to use gautil coverage on my Mac to produce the coverage graphs (and zoomed out pile-up) prior to loading .bam files into GenomeBrowse, as if I have a lot of .bam files and if they are only processed one by one in GenomeBrowse GUI, it takes a very long time.

I am running the following command from within the GenomeBrowse 'Tools' folder where gautil is located:

./gautil coverage /Users/username/examplefolder/INPUT.bam --refFolder="/Users/username/Library/Application Support/Golden Helix/Common Data/Annotations/"

And the output I receive is as follows:

Unable to find reference sequence source for build: 
Ran into errors: Unable to match data in this source with an existing reference sequence.
Reference sequence must have matching chromosome names and lengths.

It seems to me that gautil is unable to identify which genome assembly my alignments are to in my .bam. When I drag and drop the same .bam file into GenomeBrowse it is able to do the computation fine, so I am not sure what the problem is. I have tried using different .bam files and also I have tried specifying the .tsf reference sequence file path directly instead of specifying the path to the folder containing it, but these didn't work. A colleague of mine seems to be doing the same thing as I am doing on Windows but having it work, so I am wondering whether this is a Mac-specific issue, or whether I am making some mistake in replicating his method.

edit retag flag offensive close merge delete